通信プロトコル

EDIINT AS2 通信ライブラリ

EDIINTはIETF(Internet Engineering Task Force)のApplication Areaのワーキンググループ、EDIINT(Electronic Data Interchange – Internet Integration)で策定された企業間通信のための通信プロトコルです。
米ウォルマートが推奨したことから、2002年頃よりグローバル採用事例が増加し、XMLなどのドキュメントをサポートできるEDIプロトコルとして長い実績を持っています。

インターネット、VAN、専用線などを通じて、XMLなどのドキュメントのセキュアな送受信を目的としており、リアルタイムにデータを交換できるのが特徴です。
セキュリティ機能として電子署名と暗号化を使用することで、データの完全性、真正性を保証することができます。
また開封通知であるMDNを送信者側に返信することで、送信否認・受信否認防止が実現可能です。
AS2はHTTPを利用したプロトコルですが、この他に、SMTPを利用したAS1、FTPを利用したAS3が存在します。
当社のX-CORE Message Serverでは、AS2のみをサポートしています。 AS2は2005年にIETFによりRFC4130として定められました。 X-CORE Message Server はXMLなどで表現されたビジネス文書(伝票・電文)をセキュアに送受信し、かつ確実に取引先が受け取ったことを確認することが可能なプロトコルとして、取引量が多く、取引先とのリアルタイムなデータ送受信を実現したい企業様向けの仕様となっています。
利用には、自社、および、取引先(VANサービス)がServer-Server型のBtoBサーバを導入している必要があります。
AS2は既存のRFC標準で規定されているシンタックスを組み合わせています。具体的には以下表に示す標準にしたがっています。

■ AS2を構成する標準

標準 対応するRFC 備考
1 HTTP v1.1 RFC2616 トランスポート層プロトコル
2 EDI content RFC1767 "Application/EDI-X12"などcontent typeを定義
3 MIME RFC2045,RFC2046,RFC2049 "content-type""multipart"などの定義や7bit US-ASCⅡをcanonical characterにするなどの定義
4 MDN(Message Disposition Notification) RFC3798 フォーマットとシンタックスを定義
5 Multipart-report RFC3462 "Multipart-report"やMDN RFC3798をサポートする定義
6 S/MIME v3.1 RFC3851,RFC3852 メッセージのスペックと暗号化のメッセージ文法
"application/pkcs7-signature"
"application/pkcs-mime"を定義
7 XML Media Type RFC3023 "application/xml"のcontent typeを定義
8 Security Multipart for MIME RFC1847 "Multipart/Signed","Multipart/Encrypted"を定義

X-CORE Message Server AS2 機能仕様

■ AS2の機能位一覧
Function Description EDIINT AS2
Requirement
Level
対応状態
集信 配信
TRANSPORT ■EDIINT AS2
AS2 Packaging メッセージパッケージング REQUIRE ◎ ◎
Sync Reply Module 同期応答機能 REQUIRE ◎ ◎
Async Reply Module 非同期応答機能 REQUIRE ◎ ◎
Reliable Module 通信機能の制御設定(MDN要求設定) OPTIONAL ◎ ◎
Reliable Module Extention1 通信機能の制御設定(MDN応答タイムアウト) ADDTIONAL ◎ ◎
Reliable Module Extention2 通信機能の制御設定(MDN応答無視設定) ADDTIONAL ◎ ◎
Reliable Module Extention3 高信頼性通信機能(再送回数設定、再送間隔設定) ADDTIONAL ◎ ◎
Payload Compress Module AS2 1.1に対応したデータ圧縮 OPTIONAL ◎ ◎
AS2 Packaging Extention 対応Content-Type拡張 OPTIONAL ◎ ◎
Proxy Module プロキシ対応(集信側はプロキシ経由受信) ADDTIONAL ◎ ◎
Configuration Reload Module 通信設定ファイル(CPA/CPAリスト)の再ロード ADDTIONAL ◎ ◎
Sync Error MDN Module エラーMDN応答対バックエンド同期機能 ADDTIONAL ◎ ◎
SECURITY ■EDIINT AS2
Security Module セキュリティ機能(署名検証など) REQUIRE ◎ ◎
AS2 Security Module
(Encryption)
メッセージの暗号化 REQUIRE ◎ ◎
AS2 Security Module
(Signature)
メッセージの署名、MDNメッセージの署名 REQUIRE ◎ ◎
AS2 Security Module Extention1
(Signature)
署名検証に使用する電子証明書をパートナーごとに切り替える ADDTIONAL ◎ ◎
AS2 Security Module Extention2
(Signature)
応答メッセージ(MDN)への署名を制御する ADDTIONAL ◎ ◎
HTTPS(SSL) Server Authentication SSLサーバー証明書に対応した通信(WASの実装を使用) OPTIONAL ◎ -
HTTPS(SSL) Server Authentication
by Partner
パートナーごとにサーバ認証時の連鎖ルート証明書を使い分ける(配信時) ADDTIONAL - ◎
HTTPS(SSL) Client Authentication SSLクライアント証明書に対応した通信 OPTIONAL ◎ ◎
HTTPS(SSL) Client Authentication
by Partner
パートナー毎にクライアント証明書と連鎖ルート証明書を使い分ける ADDTIONAL ◎ ◎
HTTP(S) Basic Authentication ベーシック認証を行う OPTIONAL ◎ ◎
HTTP(S) Basic Authentication
by Partner
ベーシック認証をパートナーによって有効/無効を切り替えて行う ADDTIONAL ◎ ◎
OTHERS ■EDIINT AS2
AS2 Message Transaction DB
for DB2
メッセージトランザクションデータベースのDB2実装への変更 ADDTIONAL ◎ ◎
MSH/MSI Logging Extention ログ出力内容追加 ADDTIONAL ◎ ◎

◎: 対応済 ×:対応予定無 -:実装スキームなし △:別途相談
REQUIRE:プロトコル規定において実装が必須とされている項目
OPTIONAL:プロトコル規定において実装がオプションとされている項目
ADDITIONAL:プロトコルに規定がない項目(製品固有項目)


製品に関するお問合せ

電話でのお問合せ

本社  0774-98-3873

製品サポート
お問い合わせフォーム